Electrical Troubleshooting

Difficulty:  Medium, can be tough!
Warning:  High electric currents can be dangerous, take appropriate precautions
Recommended Tools:  Multimeter

Dirt bike electrical systems are relatively simple and yet there is a lot of confusion around that can make troubleshooting tough.  The 1992 Suzuki RM125 that I bought came with a CDI unit from a Chinese pit bike and would spark sometimes and then nothing.  This guide will go through the diagnostic process with a focus on this bike but apart from some of the fine details, the overall process and techniques apply to many other bikes.  A lot of the dirt bikes of that era had very similar electrical systems.

To start with, it is really useful to have the wiring diagram for your bike defining the colours of the wires and their routing.  This is the wiring diagram I found that matches my bike, it is from the service manual.

RM125Wiring

The magneto consists of a stator that holds an exciter coil (B/R and R/W wires) and a pick-up (R and G wires), along with a magnetic flywheel that generates a high voltage Alternating Current in the exciter coil when it rotates.  On the outside of the flywheel is a metallic tab that generates a low voltage AC pulse when the tab passes the pick-up coil.  Both of these are fed to the CDI unit where the high voltage charges a capacitor and the low voltage pulse indicates to the CDI unit that the piston is something like getting close to Top Dead Centre triggering the CDI to discharge the capacitor into the primary winding of the ignition coil.  The the secondary winding of the ignition coil magnifies the voltage much higher as it passes into the spark plug where the very high voltage enables the electricity to jump across the air gap at the tip creating a spark and igniting the fuel in the cylinder – hence Capacitor Discharge Ignition.

So what do you do if you are not getting any spark or worse still, the spark is intermittent?  The best place to start is with the cheap, easy stuff, try a known good spark plug if you have one available.  Wait a second, lets back up here and quickly go over how to check for a spark.  First of all remove the spark plug cap from the spark plug and remove the spark plug from the cylinder head.  Now put the spark plug cap back on the spark plug and lay the plug on the cylinder head ensuring good electrical contact to ground the plug.  IMPORTANT: MAKE SURE THE IGNITION IS ON if you have a key or run switch – in my case,  I just disconnected the kill switch from the CDI unit.  Make sure hands are clear and no-one is touching the spark plug and give the kick start some solid kicks – you should clearly see a blue or orange spark.

Next thing to check is the ignition coil.  For my bike, the manual states that there should be a resistance of 11K to 16K Ohms (11,000 to 16,000 Ohms) across the secondary winding of the coil.  IMPORTANT: Ensure that your multi-meter is set correctly.  If you have it set to 200 Ohms for example, the meter will often just give an infinite resistance when the measurement is outside the upper limit of the set range.  For this test my multimeter was set at 20K Ohms, the positive probe was pushed into the spark plug cap and the negative probe was pressed against the ground on the coil where it is mounted to the frame and gave me a reading of 17.8K Ohms.  That was a little outside the specified range but since my bike would give a nice spark sometimes, I did not see this as a smoking gun and carried on with further testing.  The primary winding was tested by connecting the positive probe to the terminal on the coil (W/L wire) and again the negative probe was contacting the coil ground.  For this measurement the range was only 0 – 1 Ohms so the multimeter was set at 20 Ohms and gave a reading of 0.8 Ohms.

The next thing to check is the coils on the stator.  First of all disconnect the exciter coil wires (B/R and R/W) and measure the resistance across them (not across the wires going to the CDI unit obviously).  The manual specifies a range of 100 – 200 Ohms so again using the 200 Ohm setting on the multi-meter, I got 132 Ohms, nice.  While you’re in here, you can also check that the stator is generating voltage.  Switch the multi-meter over to 200V AC and with a good firm kick you should get around 100V.
Same procedure and multi-meter settings for checking the pick-up coil, disconnect the pick-up coil (R and G wires), the resistance should be 80 – 200 Ohms, I got 99 Ohms.

If everything checks out OK so far, it’s time to look at the CDI unit.  You can only really test the CDI if you have the appropriate test values for your unit, again I found these in the service manual.

CDItestLarge

There are 7 wires coming out of the CDI unit, the colours are listed underneath the table.  Each of these wires are listed in the first row of the table and again in the first column.  By connecting the negative probe of your multi-meter to one of the wires in the first column and the positive probe to another wire from the first row, you can read the resistance and compare it to the value in the table.  For example, with the negative probe connected to the Green wire and the positive probe connected to the Red wire, and your multi-meter set at 20K Ohms, you should get a reading between 2K – 5K Ohms.

This is where my troubleshooting ground to a halt since the CDI on my bike was not OEM.  With everything else checking out, more or less, and since I could get an intermittent spark, I decided to try a used CDI unit.  The first one I bought was for a 1987 RM 125 but was DOA, a second one that was for an unknown year was also DOA with 2 wires showing no connection at all.  I tried cutting it open to see if it was an easy fix but it seems that they put the circuit board in a plastic box and top it up with silicone so it’s very difficult to get to anything.
Back to eBay to find another CDI unit, this time I decided to go for a brand new aftermarket unit.  When it arrived I was nervous about hooking it up and double checked all my wiring and resistance measurements of the stator and pick-up coils.  I connected it up and … no spark!!  Actually I got a single spark if I held the kill switch??  I read a similar story online and the guy swapped the red and green pickup wires round to get it working – I didn’t think that would make any difference because it is just a trigger signal but as I was thinking about it, I wondered if the capacitor could have been negatively charged causing the spark when the kill switch was grounded.  I swapped the red and black stator wires and bingo, the plug was kicking out nice strong sparks!!!  The weird thing is that the stator wires looked as though they were original and I only repaired the pickup wiring.

At last it is running – woohoo!!  Next the carb needs setting up.